TP-Link TL-WR1043ND V1.8 [OpenWRT Backfire 10.03.1-rc4]

 

The following guide show how to flash from factory to OpenWRT, based on OpenWRT Backfire 10.03.1-rc4 as an example to walk through.
After which I setup the device as a standalone BT download using Transmission.

Please refer HERE if you would like to setup the device for UniFi or 3 digits multiple vlans setup.


Flash method: Web Gui, factory to OpenWRT: openwrt-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin

 

Factory Firmware: http://www.tp-link.com/en/products/details/?categoryid=238&model=TL-WR1043ND#down (Select the correct version!)


Flash from factory to OpenWRT

 

Download the OpenWRT bin file, go to "System Tools --> Firmware Upgrade", browse the file and click Upgrade

Click OK to continue

DO NOT touch anything until it's completed !!

 

 

Once the upgrade is done, during first time access,  default IP is 192.168.1.1, username is "root", just click "login" to continue.

Go straight to "System --> Admin Password"

Change the root's password accordingly, click "Submit".

 

Basically firmware flashing from factory to OpenWRT is completed.

 


 

Setup As Standalone and Attach To Existing LAN

Please take note this portion may or may not be applicable to you.

My main purpose is to setup this device as standalone BT client (Transmission) and FTP usage purposes, I do not intend to use this device as router gateway and/or WiFi.

 

Since I already have a router gateway with DHCP & DNS on existing LAN, so first I connect the computer to the device's LAN to configure the following.

Click on the "Administration" button on the right section first, the go to "Network --> LAN"

Assign static IP (eg, 192.168.1.80), LAN gateway & DNS (eg, mine is 192.168.1.1)
Click drop-down to select "DNS" and click "Add"

Enter relevant information as follows, click "Save & Apply" to continue

 

Close the browser, disconnect the computer from the device's LAN.
Plug in the device's LAN port to existing LAN, plug-in the computer to the device's LAN port, it should get the IP assign directly from the gateway 192.168.1.1

Open the browser to access the device, enter username & password accordingly.

Go to "Network --> Interface --> WAN"

Select WAN Protocol to "none" since I'm not using it as router gateway.

 

Disable DHCP function

 

 

Disable DNS function

 

 

Disable Firewall & DHCP/DNS services  (main purpose is to preserve hardware resource.)

 

Re-boot the device to take effect

 

 

The device is configured as standalone station now, ready to install and setup the following:


X

Right Click

No right click